EtherChannel Tutorial

In this short article we will configure some Layer 2 EtherChannel links. These are used to aggregate switchports to increase bandwidth and provide redundancy. I am running a four port EtherChannel from my Edge router to my Core switch. This article is useful for CCNP (BCMSN) studies.

First we will configure our switchports, then we will configure the Port-Channel interface, then we’ll look at some show commands.
Here is the switchport configuration:
 
interface range GigabitEthernet0/23 - 26
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 10
 switchport mode trunk
 channel-group 1 mode on

We’ve set the trunking encapsulation to 802.1q and turn trunking on, then we set the native VLAN (I use 10), the command to note is “channel-group”, we have made the group 1 and set the mode to “on”, this means the port will not negotiate to become an EtherChannel, it just is.
Next we configure the Port-Channel interface:

interface Port-channel1
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 10
 switchport mode trunk
 
This is just a logical interface (somewhat similar to a Loopback). We do the same trunk configuration here.
Now you will perform the same configuration on the other side, which I will leave out. Let’s look at some show commands:

CORE#sh etherchannel 1 summ
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator
 
        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port
 
Number of channel-groups in use: 1
Number of aggregators:           1
 
Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)          -        Gi0/21(P)   Gi0/23(P)   Gi0/25(P)
                                 Gi0/27(P)
 
This is currently my favorit show command, it sums things up nicely, without too much irrelevant information. It is telling us that our Layer 2 EtherChannel is up and working.
Here’s another useful show command:

CORE#sh etherchannel 1 port-channel
                Port-channels in the group:
                ---------------------------
 
Port-channel: Po1
------------
 
Age of the Port-channel   = 1d:18h:54m:09s
Logical slot/port   = 2/1          Number of ports = 4
GC                  = 0x00000000      HotStandBy port = null
Port state          = Port-channel Ag-Inuse
Protocol            =    -
Port security       = Disabled
 
Ports in the Port-channel:
 
Index   Load   Port     EC state        No of bits
------+------+------+------------------+-----------
  0     00     Gi0/21   On                 0
  0     00     Gi0/23   On                 0
  0     00     Gi0/25   On                 0
  0     00     Gi0/27   On                 0
 
Time since last port bundled:    1d:16h:44m:47s    Gi0/25
Time since last port Un-bundled: 1d:17h:00m:25s    Gi0/27
 
This is similar information, but it also tells you how long the EtherChannel has been up, which can be helpful for troubleshooting.

We now have a four port, 400Mb/s (the ports on the Edge router are only FastEthernet) EtherChannel. This has been pretty brief, but there isn’t much more to it without getting into the negotiation protocols, which I try to avoid using.

Comentarios

Entradas populares de este blog

Guía de herramientas básicas para estudiantes: 31 apps y webs imprescindibles para ayudarte con los estudios

Comando FOR para archivos BAT

How to Fix Failed to Connect a Hyper-V Standalone to Veeam Backup